summaryrefslogtreecommitdiff
path: root/dev-java/openjdk
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-04-28 10:38:39 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-04-28 10:39:49 -0400
commite050e57bc73b42f73ead76ea1517c77eea17ab45 (patch)
tree11c06baf764b616d3091b6a5a7a159782e2c7952 /dev-java/openjdk
parent8c919cbaa0a6511c8b8c333142a309ffd4995624 (diff)
downloadgentoo-overlay-e050e57bc73b42f73ead76ea1517c77eea17ab45.tar.xz
gentoo-overlay-e050e57bc73b42f73ead76ea1517c77eea17ab45.zip
dev-java/*openjdk*: various fixes
- merge SLOT envs into one, less work when bumping (we don't support 8 anyways) - sync ::gentoo
Diffstat (limited to 'dev-java/openjdk')
-rw-r--r--dev-java/openjdk/files/openjdk.env.sh (renamed from dev-java/openjdk/files/openjdk-16.env.sh)0
-rw-r--r--dev-java/openjdk/openjdk-16.0.1_p9.ebuild11
2 files changed, 7 insertions, 4 deletions
diff --git a/dev-java/openjdk/files/openjdk-16.env.sh b/dev-java/openjdk/files/openjdk.env.sh
index 96c4be7..96c4be7 100644
--- a/dev-java/openjdk/files/openjdk-16.env.sh
+++ b/dev-java/openjdk/files/openjdk.env.sh
diff --git a/dev-java/openjdk/openjdk-16.0.1_p9.ebuild b/dev-java/openjdk/openjdk-16.0.1_p9.ebuild
index 0a506f5..7a5b20f 100644
--- a/dev-java/openjdk/openjdk-16.0.1_p9.ebuild
+++ b/dev-java/openjdk/openjdk-16.0.1_p9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -22,6 +22,7 @@ IUSE="alsa cups debug doc examples gentoo-vm headless-awt javafx +jbootstrap +pc
COMMON_DEPEND="
media-libs/freetype:2=
media-libs/giflib:0/7
+ media-libs/harfbuzz:=
media-libs/libpng:0=
media-libs/lcms:2=
sys-libs/zlib
@@ -85,7 +86,7 @@ openjdk_check_requirements() {
pkg_pretend() {
openjdk_check_requirements
if [[ ${MERGE_TYPE} != binary ]]; then
- has ccache ${FEATURES} && die "FEATURES=ccache doesn't work with ${PN}"
+ has ccache ${FEATURES} && die "FEATURES=ccache doesn't work with ${PN}, bug #677876"
fi
}
@@ -123,7 +124,9 @@ src_configure() {
--with-extra-cflags="${CFLAGS}"
--with-extra-cxxflags="${CXXFLAGS}"
--with-extra-ldflags="${LDFLAGS}"
+ --with-freetype=system
--with-giflib=system
+ --with-harfbuzz=system
--with-lcms=system
--with-libjpeg=system
--with-libpng=system
@@ -143,7 +146,7 @@ src_configure() {
)
if use javafx; then
- local zip="${EROOT%/}/usr/$(get_libdir)/openjfx-${SLOT}/javafx-exports.zip"
+ local zip="${EPREFIX%/}/usr/$(get_libdir)/openjfx-${SLOT}/javafx-exports.zip"
if [[ -r ${zip} ]]; then
myconf+=( --with-import-modules="${zip}" )
else
@@ -215,7 +218,7 @@ src_install() {
einfo "Creating the Class Data Sharing archives and disabling usage tracking"
"${ddest}/bin/java" -server -Xshare:dump -Djdk.disableLastUsageTracking || die
- use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}-${SLOT}.env.sh
+ use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}.env.sh
java-vm_revdep-mask
java-vm_sandbox-predict /dev/random /proc/self/coredump_filter