summaryrefslogtreecommitdiff
path: root/dev-java
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2022-06-07 14:25:48 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2022-06-07 14:25:48 -0400
commit32fa1c545f4a6bf342f77148e3edfec822883409 (patch)
treefe84ea74ad8c6a651d21634ae76f407d00d8d9b3 /dev-java
parent27b7dc1860616ae9acc46c05af0a242c80553aa0 (diff)
downloadgentoo-overlay-32fa1c545f4a6bf342f77148e3edfec822883409.tar.xz
gentoo-overlay-32fa1c545f4a6bf342f77148e3edfec822883409.zip
dev-java/openj9-openjdk-jre-bin: sync openjdk-jre-bin::gentoo
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-11.0.15.10.0.32.0.ebuild26
-rw-r--r--dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-17.0.3.7.0.32.0.ebuild26
2 files changed, 32 insertions, 20 deletions
diff --git a/dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-11.0.15.10.0.32.0.ebuild b/dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-11.0.15.10.0.32.0.ebuild
index 52c9fd3..da507a5 100644
--- a/dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-11.0.15.10.0.32.0.ebuild
+++ b/dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-11.0.15.10.0.32.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit eapi7-ver java-vm-2 toolchain-funcs
+inherit java-vm-2
abi_uri() {
echo "${2-$1}? (
@@ -52,8 +52,13 @@ QA_PREBUILT="*"
S="${WORKDIR}/jdk-${JDK_PV}-jre"
src_install() {
- local dest="/opt/${P}"
- local ddest="${ED%/}/${dest#/}"
+ local dest="/opt/${PN}-${SLOT}"
+ local ddest="${ED}/${dest#/}"
+
+ # Not sure why they bundle this as it's commonly available and they
+ # only do so on x86_64. It's needed by libfontmanager.so. IcedTea
+ # also has an explicit dependency while Oracle seemingly dlopens it.
+ rm -vf lib/libfreetype.so || die
# Oracle and IcedTea have libjsoundalsa.so depending on
# libasound.so.2 but AdoptOpenJDK only has libjsound.so. Weird.
@@ -66,16 +71,17 @@ src_install() {
fi
rm -v lib/security/cacerts || die
- dosym ../../../../etc/ssl/certs/java/cacerts "${dest}"/lib/security/cacerts
+ dosym -r /etc/ssl/certs/java/cacerts "${dest}"/lib/security/cacerts
dodir "${dest}"
cp -pPR * "${ddest}" || die
- # provide stable symlink
- dosym "${P}" "/opt/${PN}-${SLOT}"
-
- use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}.env.sh
+ java-vm_install-env "${FILESDIR}"/${PN}.env.sh
java-vm_set-pax-markings "${ddest}"
java-vm_revdep-mask
java-vm_sandbox-predict /dev/random /proc/self/coredump_filter
}
+
+pkg_postinst() {
+ java-vm-2_pkg_postinst
+}
diff --git a/dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-17.0.3.7.0.32.0.ebuild b/dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-17.0.3.7.0.32.0.ebuild
index 52c9fd3..da507a5 100644
--- a/dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-17.0.3.7.0.32.0.ebuild
+++ b/dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-17.0.3.7.0.32.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit eapi7-ver java-vm-2 toolchain-funcs
+inherit java-vm-2
abi_uri() {
echo "${2-$1}? (
@@ -52,8 +52,13 @@ QA_PREBUILT="*"
S="${WORKDIR}/jdk-${JDK_PV}-jre"
src_install() {
- local dest="/opt/${P}"
- local ddest="${ED%/}/${dest#/}"
+ local dest="/opt/${PN}-${SLOT}"
+ local ddest="${ED}/${dest#/}"
+
+ # Not sure why they bundle this as it's commonly available and they
+ # only do so on x86_64. It's needed by libfontmanager.so. IcedTea
+ # also has an explicit dependency while Oracle seemingly dlopens it.
+ rm -vf lib/libfreetype.so || die
# Oracle and IcedTea have libjsoundalsa.so depending on
# libasound.so.2 but AdoptOpenJDK only has libjsound.so. Weird.
@@ -66,16 +71,17 @@ src_install() {
fi
rm -v lib/security/cacerts || die
- dosym ../../../../etc/ssl/certs/java/cacerts "${dest}"/lib/security/cacerts
+ dosym -r /etc/ssl/certs/java/cacerts "${dest}"/lib/security/cacerts
dodir "${dest}"
cp -pPR * "${ddest}" || die
- # provide stable symlink
- dosym "${P}" "/opt/${PN}-${SLOT}"
-
- use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}.env.sh
+ java-vm_install-env "${FILESDIR}"/${PN}.env.sh
java-vm_set-pax-markings "${ddest}"
java-vm_revdep-mask
java-vm_sandbox-predict /dev/random /proc/self/coredump_filter
}
+
+pkg_postinst() {
+ java-vm-2_pkg_postinst
+}