summaryrefslogtreecommitdiff
path: root/dev-libs/aml
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-09-02 09:11:41 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-09-02 09:22:59 -0400
commitda498b2728a65dfd6ec22282a34725bf4ee863d8 (patch)
tree4fea8d8c370d9c6f3ea8debba3029a53916c294f /dev-libs/aml
parent4da75e5d0e0af24c9c8495c2a8c3500a27b73d10 (diff)
downloadgentoo-overlay-da498b2728a65dfd6ec22282a34725bf4ee863d8.tar.xz
gentoo-overlay-da498b2728a65dfd6ec22282a34725bf4ee863d8.zip
dev-libs/aml: 0.1.0 bump
Diffstat (limited to 'dev-libs/aml')
-rw-r--r--dev-libs/aml/Manifest1
-rw-r--r--dev-libs/aml/aml-0.1.0.ebuild32
-rw-r--r--dev-libs/aml/aml-9999.ebuild2
3 files changed, 34 insertions, 1 deletions
diff --git a/dev-libs/aml/Manifest b/dev-libs/aml/Manifest
new file mode 100644
index 0000000..cd50f0b
--- /dev/null
+++ b/dev-libs/aml/Manifest
@@ -0,0 +1 @@
+DIST aml-0.1.0.tar.gz 19267 BLAKE2B 9021ae97137a7c15bb42fe88be212522f73b1e0807389c09b743382f9976534567fad49ea4664114ee952a9eb5afb8cd94df10677178deaf18c326bd690e271d SHA512 d22cc6b597b90fc9df830e7e444e0cd2aac87e0fd882c8daf3485b3d5825d2b5b86a32ecc612cb5d907e66a0aa22911f4aae3e9b9267c0278b115ff726879d80
diff --git a/dev-libs/aml/aml-0.1.0.ebuild b/dev-libs/aml/aml-0.1.0.ebuild
new file mode 100644
index 0000000..ca406f5
--- /dev/null
+++ b/dev-libs/aml/aml-0.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Another Main Loop"
+HOMEPAGE="https://github.com/any1/aml"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/any1/aml.git"
+else
+ SRC_URI="https://github.com/any1/aml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use examples)
+ )
+
+ meson_src_configure
+}
diff --git a/dev-libs/aml/aml-9999.ebuild b/dev-libs/aml/aml-9999.ebuild
index 48ae40e..a4d4583 100644
--- a/dev-libs/aml/aml-9999.ebuild
+++ b/dev-libs/aml/aml-9999.ebuild
@@ -11,7 +11,7 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/any1/aml.git"
else
- SRC_URI="https://github.com/any1/aml/archive/v${PV}.tar.gz"
+ SRC_URI="https://github.com/any1/aml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
fi
LICENSE="ISC"