summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/aml/Manifest1
-rw-r--r--dev-libs/aml/aml-0.1.0.ebuild32
-rw-r--r--dev-libs/aml/aml-9999.ebuild2
-rw-r--r--net-libs/neatvnc/Manifest1
-rw-r--r--net-libs/neatvnc/metadata.xml3
-rw-r--r--net-libs/neatvnc/neatvnc-0.2.0.ebuild41
-rw-r--r--net-libs/neatvnc/neatvnc-9999.ebuild12
-rw-r--r--net-misc/wayvnc/Manifest1
-rw-r--r--net-misc/wayvnc/wayvnc-0.2.0.ebuild40
-rw-r--r--net-misc/wayvnc/wayvnc-9999.ebuild13
10 files changed, 135 insertions, 11 deletions
diff --git a/dev-libs/aml/Manifest b/dev-libs/aml/Manifest
new file mode 100644
index 0000000..cd50f0b
--- /dev/null
+++ b/dev-libs/aml/Manifest
@@ -0,0 +1 @@
+DIST aml-0.1.0.tar.gz 19267 BLAKE2B 9021ae97137a7c15bb42fe88be212522f73b1e0807389c09b743382f9976534567fad49ea4664114ee952a9eb5afb8cd94df10677178deaf18c326bd690e271d SHA512 d22cc6b597b90fc9df830e7e444e0cd2aac87e0fd882c8daf3485b3d5825d2b5b86a32ecc612cb5d907e66a0aa22911f4aae3e9b9267c0278b115ff726879d80
diff --git a/dev-libs/aml/aml-0.1.0.ebuild b/dev-libs/aml/aml-0.1.0.ebuild
new file mode 100644
index 0000000..ca406f5
--- /dev/null
+++ b/dev-libs/aml/aml-0.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Another Main Loop"
+HOMEPAGE="https://github.com/any1/aml"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/any1/aml.git"
+else
+ SRC_URI="https://github.com/any1/aml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use examples)
+ )
+
+ meson_src_configure
+}
diff --git a/dev-libs/aml/aml-9999.ebuild b/dev-libs/aml/aml-9999.ebuild
index 48ae40e..a4d4583 100644
--- a/dev-libs/aml/aml-9999.ebuild
+++ b/dev-libs/aml/aml-9999.ebuild
@@ -11,7 +11,7 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/any1/aml.git"
else
- SRC_URI="https://github.com/any1/aml/archive/v${PV}.tar.gz"
+ SRC_URI="https://github.com/any1/aml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
fi
LICENSE="ISC"
diff --git a/net-libs/neatvnc/Manifest b/net-libs/neatvnc/Manifest
new file mode 100644
index 0000000..666d668
--- /dev/null
+++ b/net-libs/neatvnc/Manifest
@@ -0,0 +1 @@
+DIST neatvnc-0.2.0.tar.gz 549524 BLAKE2B 51d47232992af52c947af7172f09bf8bdfad0022543fa7962da84a1a830ba0c5c4e4c66d890822b366e5430ebd1524b5c4f132be3699f8361e882ba497595545 SHA512 74ff4ec6a492eaeead90b5e5d789885c709e90d50f682ad127f0f364264324ed0e6c66859f4254cbe9b79ebabb20974ceded67d5cab6a5fa8fd1f664ea18b15f
diff --git a/net-libs/neatvnc/metadata.xml b/net-libs/neatvnc/metadata.xml
index 004555a..a4e99d0 100644
--- a/net-libs/neatvnc/metadata.xml
+++ b/net-libs/neatvnc/metadata.xml
@@ -5,4 +5,7 @@
<email>alex_y_xu@yahoo.ca</email>
<name>Alex Xu (Hello71)</name>
</maintainer>
+ <use>
+ <flag name="benchmarks">Build and install benchmarks.</flag>
+ </use>
</pkgmetadata>
diff --git a/net-libs/neatvnc/neatvnc-0.2.0.ebuild b/net-libs/neatvnc/neatvnc-0.2.0.ebuild
new file mode 100644
index 0000000..458f18a
--- /dev/null
+++ b/net-libs/neatvnc/neatvnc-0.2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A liberally licensed VNC server library with a clean interface"
+HOMEPAGE="https://github.com/any1/neatvnc"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/any1/neatvnc.git"
+else
+ SRC_URI="https://github.com/any1/neatvnc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="benchmarks examples +jpeg ssl"
+
+DEPEND="
+ jpeg? ( media-libs/libjpeg-turbo )
+ ssl? ( net-libs/gnutls:= )
+ dev-libs/aml
+ sys-libs/zlib
+ x11-libs/pixman
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use benchmarks)
+ $(meson_use examples)
+ $(meson_feature jpeg)
+ $(meson_feature ssl tls)
+ )
+
+ meson_src_configure
+}
diff --git a/net-libs/neatvnc/neatvnc-9999.ebuild b/net-libs/neatvnc/neatvnc-9999.ebuild
index 6aff3d8..c1f9ddf 100644
--- a/net-libs/neatvnc/neatvnc-9999.ebuild
+++ b/net-libs/neatvnc/neatvnc-9999.ebuild
@@ -11,13 +11,13 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/any1/neatvnc.git"
else
- SRC_URI="https://github.com/any1/neatvnc/archive/v${PV}.tar.gz"
+ SRC_URI="https://github.com/any1/neatvnc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
fi
LICENSE="ISC"
SLOT="0"
KEYWORDS=""
-IUSE="examples +jpeg ssl"
+IUSE="benchmarks examples +jpeg ssl"
DEPEND="
jpeg? ( media-libs/libjpeg-turbo )
@@ -29,15 +29,11 @@ DEPEND="
RDEPEND="${DEPEND}"
BDEPEND=""
-src_prepare() {
- default
- sed -i -e '/x86_64-simd/s/^/#/' meson.build || die
-}
-
src_configure() {
local emesonargs=(
+ $(meson_use benchmarks)
$(meson_use examples)
- $(meson_feature jpeg tight-encoding)
+ $(meson_feature jpeg)
$(meson_feature ssl tls)
)
diff --git a/net-misc/wayvnc/Manifest b/net-misc/wayvnc/Manifest
new file mode 100644
index 0000000..a4bc175
--- /dev/null
+++ b/net-misc/wayvnc/Manifest
@@ -0,0 +1 @@
+DIST wayvnc-0.2.0.tar.gz 43615 BLAKE2B 7c663193160c97f3c1ac8641a2a9ccad99a9a4ca1d538ab64fe07fc5af759fb8abfac0b5fa9426de0d5e4453c3b60410edd882ffbf2a5d536b1634c714612f6d SHA512 42798ba2bcb96cb718bfe41c48a1525764ac26ea073ba69e26d327d422a379e93e5b57ba03290ca26d3c49c610e68a8459186fcf39998e74af7150df210ad9be
diff --git a/net-misc/wayvnc/wayvnc-0.2.0.ebuild b/net-misc/wayvnc/wayvnc-0.2.0.ebuild
new file mode 100644
index 0000000..54bcd82
--- /dev/null
+++ b/net-misc/wayvnc/wayvnc-0.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A VNC server for wlroots based Wayland compositors"
+HOMEPAGE="https://github.com/any1/wayvnc"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/any1/wayvnc.git"
+else
+ SRC_URI="https://github.com/any1/wayvnc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gbm"
+
+DEPEND="
+ dev-libs/aml
+ dev-libs/wayland
+ net-libs/neatvnc
+ virtual/opengl
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+ gbm? ( media-libs/mesa )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-libs/wayland"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_features gbm screencopy-dmabuf)
+ )
+
+ meson_src_configure
+}
diff --git a/net-misc/wayvnc/wayvnc-9999.ebuild b/net-misc/wayvnc/wayvnc-9999.ebuild
index a09e5dc..5b298a0 100644
--- a/net-misc/wayvnc/wayvnc-9999.ebuild
+++ b/net-misc/wayvnc/wayvnc-9999.ebuild
@@ -11,13 +11,13 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/any1/wayvnc.git"
else
- SRC_URI="https://github.com/any1/wayvnc/archive/v${PV}.tar.gz"
+ SRC_URI="https://github.com/any1/wayvnc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
fi
LICENSE="ISC"
SLOT="0"
KEYWORDS=""
-IUSE="examples"
+IUSE="gbm"
DEPEND="
dev-libs/aml
@@ -26,6 +26,15 @@ DEPEND="
virtual/opengl
x11-libs/libxkbcommon
x11-libs/pixman
+ gbm? ( media-libs/mesa )
"
RDEPEND="${DEPEND}"
BDEPEND="dev-libs/wayland"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_features gbm screencopy-dmabuf)
+ )
+
+ meson_src_configure
+}