summaryrefslogtreecommitdiff
path: root/dev-libs
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-06-25 21:31:09 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-06-25 21:31:56 -0400
commitfad053addbbd3f0768a6c68506c9e78f24d0b7f4 (patch)
tree874f3b14573b6dd097a82c293565ca83bd453914 /dev-libs
parent598041ffdb7ad132a7d295aa57b49fbf70d6cf2e (diff)
downloadgentoo-overlay-fad053addbbd3f0768a6c68506c9e78f24d0b7f4.tar.xz
gentoo-overlay-fad053addbbd3f0768a6c68506c9e78f24d0b7f4.zip
dev-libs/highway, media-libs/libjxl: new packages
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/highway/Manifest1
-rw-r--r--dev-libs/highway/highway-0.12.2.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-libs/highway/Manifest b/dev-libs/highway/Manifest
new file mode 100644
index 0000000..30461b0
--- /dev/null
+++ b/dev-libs/highway/Manifest
@@ -0,0 +1 @@
+DIST highway-0.12.2.tar.gz 1487685 BLAKE2B 7304dc2b3b8c704aa0f138f24d7118a3d364ad5a7f1ae359dcad16444c3f02a12d1454855459290a3d0bfae5b25e7d6baec2a8c5fd00d6165cb0f6695e02b479 SHA512 857a3ecbeaf13d69b9807d6f7daf0a1dc791008c7ce0413cb20457eb057f60fa9a5836eff7cf28c884566bae746d9b7d850b3cf88767bb299f10fd1440a56e06
diff --git a/dev-libs/highway/highway-0.12.2.ebuild b/dev-libs/highway/highway-0.12.2.ebuild
new file mode 100644
index 0000000..7f21cc2
--- /dev/null
+++ b/dev-libs/highway/highway-0.12.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Performance-portable, length-agnostic SIMD with runtime dispatch"
+HOMEPAGE="https://github.com/google/highway"
+SRC_URI="https://github.com/google/highway/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-cpp/gtest )"
+RDEPEND=""
+BDEPEND=""
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test ON OFF)
+ -DHWY_SYSTEM_GTEST=ON
+ )
+ cmake_src_configure
+}