summaryrefslogtreecommitdiff
path: root/dev-libs/highway/highway-0.12.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/highway/highway-0.12.2.ebuild')
-rw-r--r--dev-libs/highway/highway-0.12.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/highway/highway-0.12.2.ebuild b/dev-libs/highway/highway-0.12.2.ebuild
new file mode 100644
index 0000000..7f21cc2
--- /dev/null
+++ b/dev-libs/highway/highway-0.12.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Performance-portable, length-agnostic SIMD with runtime dispatch"
+HOMEPAGE="https://github.com/google/highway"
+SRC_URI="https://github.com/google/highway/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-cpp/gtest )"
+RDEPEND=""
+BDEPEND=""
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test ON OFF)
+ -DHWY_SYSTEM_GTEST=ON
+ )
+ cmake_src_configure
+}