summaryrefslogtreecommitdiff
path: root/net-misc/wayvnc/wayvnc-0.4.0.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-01-21 21:55:43 -0500
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-01-21 21:55:43 -0500
commit2c9a578b2dfef5df666a866897c30ff914a5c57a (patch)
treec9817d2890df51acb2d61667e054fca5504b0849 /net-misc/wayvnc/wayvnc-0.4.0.ebuild
parent59cc78eb52efa6651e7be1c79340164ed987fcdd (diff)
downloadgentoo-overlay-2c9a578b2dfef5df666a866897c30ff914a5c57a.tar.xz
gentoo-overlay-2c9a578b2dfef5df666a866897c30ff914a5c57a.zip
net-misc/wayvnc: bump
Diffstat (limited to 'net-misc/wayvnc/wayvnc-0.4.0.ebuild')
-rw-r--r--net-misc/wayvnc/wayvnc-0.4.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-misc/wayvnc/wayvnc-0.4.0.ebuild b/net-misc/wayvnc/wayvnc-0.4.0.ebuild
new file mode 100644
index 0000000..16661e8
--- /dev/null
+++ b/net-misc/wayvnc/wayvnc-0.4.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A VNC server for wlroots based Wayland compositors"
+HOMEPAGE="https://github.com/any1/wayvnc"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/any1/wayvnc.git"
+else
+ SRC_URI="https://github.com/any1/wayvnc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gbm +man systemtap"
+
+DEPEND="
+ dev-libs/aml
+ dev-libs/wayland
+ net-libs/neatvnc
+ virtual/opengl
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+ gbm? ( media-libs/mesa )
+ man? ( app-text/scdoc )
+ systemtap? ( dev-util/systemtap )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-libs/wayland"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature gbm screencopy-dmabuf)
+ $(meson_feature man man-pages)
+ $(meson_feature systemtap)
+ )
+
+ meson_src_configure
+}