summaryrefslogtreecommitdiff
path: root/sci-calculators/units/units-2.23-r1.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2024-10-01 15:17:29 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2024-10-01 15:17:29 -0400
commitaf42e1bcf3abc427f046cebd15a0e4c8dc6cc268 (patch)
treed8e92c04b4f6362739a2f0189b6c0bb407d66a15 /sci-calculators/units/units-2.23-r1.ebuild
parente245d604937b9994a92f59aed27146c557601591 (diff)
downloadgentoo-overlay-af42e1bcf3abc427f046cebd15a0e4c8dc6cc268.tar.xz
gentoo-overlay-af42e1bcf3abc427f046cebd15a0e4c8dc6cc268.zip
sci-calculators/units: upgrade to 2.23
Diffstat (limited to 'sci-calculators/units/units-2.23-r1.ebuild')
-rw-r--r--sci-calculators/units/units-2.23-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/sci-calculators/units/units-2.23-r1.ebuild b/sci-calculators/units/units-2.23-r1.ebuild
new file mode 100644
index 0000000..c5ddc81
--- /dev/null
+++ b/sci-calculators/units/units-2.23-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+inherit python-r1
+
+DESCRIPTION="Unit conversion program"
+HOMEPAGE="https://www.gnu.org/software/units/units.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="FDL-1.3 GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+units-cur"
+REQUIRED_USE="units-cur? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ sys-libs/readline:=
+ units-cur? (
+ ${PYTHON_DEPS}
+ )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.20-readerror.patch
+ "${FILESDIR}"/units_cur-urllib.patch
+)
+
+DOCS=( NEWS README )
+
+src_configure() {
+ local myconf=(
+ --sharedstatedir="${EPREFIX}"/var/lib
+ ac_cv_path_PYTHON=no
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ emake ${PN}
+}
+
+src_install() {
+ default
+
+ if use units-cur; then
+ sed \
+ -e "/^outfile/s|'.*'|'/usr/share/units/currency.units'|g" \
+ -e 's|^#!|&/usr/bin/python|g' \
+ units_cur_inst > units_cur || die
+ python_foreach_impl python_doscript units_cur
+ fi
+}