summaryrefslogtreecommitdiff
path: root/x11-apps/sx/sx-2.1.3.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-07-28 16:50:08 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-07-28 16:50:08 -0400
commitd8705b95a8ed3e817ffc0b95a8f5f2daef9b270e (patch)
treece1e02750c79e5a89e09f12f6309e80d9469d708 /x11-apps/sx/sx-2.1.3.ebuild
parent95fda03f6c47d109e717562b55f890d96adb0246 (diff)
downloadgentoo-overlay-d8705b95a8ed3e817ffc0b95a8f5f2daef9b270e.tar.xz
gentoo-overlay-d8705b95a8ed3e817ffc0b95a8f5f2daef9b270e.zip
x11-apps/sx: add 2.1.3
Diffstat (limited to 'x11-apps/sx/sx-2.1.3.ebuild')
-rw-r--r--x11-apps/sx/sx-2.1.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/x11-apps/sx/sx-2.1.3.ebuild b/x11-apps/sx/sx-2.1.3.ebuild
new file mode 100644
index 0000000..c43076d
--- /dev/null
+++ b/x11-apps/sx/sx-2.1.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Start an xorg server"
+HOMEPAGE="https://github.com/Earnestly/sx"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Earnestly/sx.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/Earnestly/sx/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+}