summaryrefslogtreecommitdiff
path: root/x11-libs
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-01-25 07:33:24 -0500
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-01-25 07:33:24 -0500
commitb78f8cd5c801ce67a9d4650000329ac49ce8961f (patch)
tree379aaa10a2eb34349fc5909dc0d60121aadbc5ff /x11-libs
parentafb9284f1b14866d911748d0932347763cbf11de (diff)
downloadgentoo-overlay-b78f8cd5c801ce67a9d4650000329ac49ce8961f.tar.xz
gentoo-overlay-b78f8cd5c801ce67a9d4650000329ac49ce8961f.zip
*/*: fixes
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/cairo/Manifest1
-rw-r--r--x11-libs/cairo/cairo-1.16.0-r5.ebuild136
-rw-r--r--x11-libs/cairo/cairo-9999.ebuild133
-rw-r--r--x11-libs/cairo/files/cairo-1.12.18-disable-test-suite.patch15
-rw-r--r--x11-libs/cairo/files/cairo-1.16.0-binutils-2.34.patch20
-rw-r--r--x11-libs/cairo/files/cairo-1.16.0-ft-Use-FT_Done_MM_Var-instead-of-free-when-available.patch30
-rw-r--r--x11-libs/cairo/files/cairo-1.16.0-pdf-add-missing-flush.patch29
-rw-r--r--x11-libs/cairo/files/cairo-1.16.0-strings.patch19
-rw-r--r--x11-libs/cairo/files/cairo-respect-fontconfig.patch13
-rw-r--r--x11-libs/cairo/metadata.xml14
10 files changed, 0 insertions, 410 deletions
diff --git a/x11-libs/cairo/Manifest b/x11-libs/cairo/Manifest
deleted file mode 100644
index a9d5249..0000000
--- a/x11-libs/cairo/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST cairo-1.16.0.tar.xz 41997432 BLAKE2B aa37edf7fdf0c952484fd0adc9281724227db93958d6e4919216b30e9017fab670bc2340e3b975737080f1f67dec24025fe0e4680e275ab7703cfb9235eb1fe0 SHA512 9eb27c4cf01c0b8b56f2e15e651f6d4e52c99d0005875546405b64f1132aed12fbf84727273f493d84056a13105e065009d89e94a8bfaf2be2649e232b82377f
diff --git a/x11-libs/cairo/cairo-1.16.0-r5.ebuild b/x11-libs/cairo/cairo-1.16.0-r5.ebuild
deleted file mode 100644
index b951785..0000000
--- a/x11-libs/cairo/cairo-1.16.0-r5.ebuild
+++ /dev/null
@@ -1,136 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic autotools multilib-minimal
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://gitlab.freedesktop.org/cairo/cairo.git"
- SRC_URI=""
-else
- SRC_URI="https://www.cairographics.org/releases/${P}.tar.xz"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-DESCRIPTION="A vector graphics library with cross-device output support"
-HOMEPAGE="https://www.cairographics.org/ https://gitlab.freedesktop.org/cairo/cairo"
-LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
-SLOT="0"
-IUSE="X aqua debug gles2-only +glib lzo opengl static-libs +svg utils valgrind"
-# gtk-doc regeneration doesn't seem to work with out-of-source builds
-#[[ ${PV} == *9999* ]] && IUSE="${IUSE} doc" # API docs are provided in tarball, no need to regenerate
-
-# Test causes a circular depend on gtk+... since gtk+ needs cairo but test needs gtk+ so we need to block it
-RESTRICT="test"
-
-BDEPEND="
- virtual/pkgconfig
- >=sys-devel/libtool-2"
-RDEPEND="
- >=media-libs/fontconfig-2.10.92[${MULTILIB_USEDEP}]
- >=media-libs/freetype-2.5.0.1:2[${MULTILIB_USEDEP}]
- >=media-libs/libpng-1.6.10:0=[${MULTILIB_USEDEP}]
- sys-libs/binutils-libs:0=[${MULTILIB_USEDEP}]
- >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
- >=x11-libs/pixman-0.32.4[${MULTILIB_USEDEP}]
- gles2-only? ( >=media-libs/mesa-9.1.6[gles2,${MULTILIB_USEDEP}] )
- glib? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
- lzo? ( >=dev-libs/lzo-2.06-r1[${MULTILIB_USEDEP}] )
- opengl? ( >=media-libs/mesa-9.1.6[egl,X(+),${MULTILIB_USEDEP}] )
- X? (
- >=x11-libs/libXrender-0.9.8[${MULTILIB_USEDEP}]
- >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
- >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
- >=x11-libs/libxcb-1.9.1[${MULTILIB_USEDEP}]
- )"
-DEPEND="${RDEPEND}
- X? ( x11-base/xorg-proto )"
-#[[ ${PV} == *9999* ]] && DEPEND="${DEPEND}
-# doc? (
-# >=dev-util/gtk-doc-1.6
-# ~app-text/docbook-xml-dtd-4.2
-# )"
-
-REQUIRED_USE="
- gles2-only? ( !opengl )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.12.18-disable-test-suite.patch
- "${FILESDIR}"/${PN}-respect-fontconfig.patch
- "${FILESDIR}"/${P}-pdf-add-missing-flush.patch
- "${FILESDIR}"/${P}-ft-Use-FT_Done_MM_Var-instead-of-free-when-available.patch
- "${FILESDIR}"/${P}-strings.patch
-)
-
-src_prepare() {
- default
-
- if has_version ">=sys-libs/binutils-libs-2.34"; then
- eapply "${FILESDIR}"/${PN}-1.16.0-binutils-2.34.patch
- fi
-
- # tests and perf tools require X, bug #483574
- if ! use X; then
- sed -e '/^SUBDIRS/ s#boilerplate test perf# #' -i Makefile.am || die
- fi
-
- # Slightly messed build system YAY
- if [[ ${PV} == *9999* ]]; then
- touch boilerplate/Makefile.am.features
- touch src/Makefile.am.features
- touch ChangeLog
- fi
-
- eautoreconf
-}
-
-multilib_src_configure() {
- local myopts
-
- [[ ${CHOST} == *-interix* ]] && append-flags -D_REENTRANT
-
- use elibc_FreeBSD && myopts+=" --disable-symbol-lookup"
-
- # [[ ${PV} == *9999* ]] && myopts+=" $(use_enable doc gtk-doc)"
-
- ECONF_SOURCE="${S}" \
- ac_cv_lib_lzo2_lzo2a_decompress=$(usex lzo) \
- econf \
- $(use_with X x) \
- $(use_enable X tee) \
- $(use_enable X xlib) \
- $(use_enable X xlib-xrender) \
- $(use_enable X xcb) \
- $(use_enable X xcb-shm) \
- $(use_enable aqua quartz) \
- $(use_enable aqua quartz-image) \
- $(use_enable debug test-surfaces) \
- $(use_enable gles2-only glesv2) \
- $(use_enable glib gobject) \
- $(use_enable opengl gl) \
- $(use_enable static-libs static) \
- $(use_enable svg) \
- $(use_enable utils trace) \
- $(use_enable valgrind) \
- --enable-ft \
- --enable-interpreter \
- --enable-pdf \
- --enable-png \
- --enable-ps \
- --enable-script \
- --disable-drm \
- --disable-directfb \
- --disable-gallium \
- --disable-qt \
- --disable-vg \
- --disable-xlib-xcb \
- ${myopts}
-}
-
-multilib_src_install_all() {
- find "${D}" -name '*.la' -delete || die
- einstalldocs
-}
diff --git a/x11-libs/cairo/cairo-9999.ebuild b/x11-libs/cairo/cairo-9999.ebuild
deleted file mode 100644
index 6a8c6b7..0000000
--- a/x11-libs/cairo/cairo-9999.ebuild
+++ /dev/null
@@ -1,133 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic autotools multilib-minimal
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://gitlab.freedesktop.org/cairo/cairo.git"
- SRC_URI=""
-else
- SRC_URI="https://www.cairographics.org/releases/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-DESCRIPTION="A vector graphics library with cross-device output support"
-HOMEPAGE="https://www.cairographics.org/ https://gitlab.freedesktop.org/cairo/cairo"
-LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
-SLOT="0"
-IUSE="X aqua debug gles2-only +glib lzo opengl static-libs +svg utils valgrind"
-# gtk-doc regeneration doesn't seem to work with out-of-source builds
-#[[ ${PV} == *9999* ]] && IUSE="${IUSE} doc" # API docs are provided in tarball, no need to regenerate
-
-# Test causes a circular depend on gtk+... since gtk+ needs cairo but test needs gtk+ so we need to block it
-RESTRICT="test"
-
-BDEPEND="
- virtual/pkgconfig
- >=sys-devel/libtool-2"
-RDEPEND="
- >=media-libs/fontconfig-2.10.92[${MULTILIB_USEDEP}]
- >=media-libs/freetype-2.5.0.1:2[${MULTILIB_USEDEP}]
- >=media-libs/libpng-1.6.10:0=[${MULTILIB_USEDEP}]
- sys-libs/binutils-libs:0=[${MULTILIB_USEDEP}]
- >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
- >=x11-libs/pixman-0.32.4[${MULTILIB_USEDEP}]
- gles2-only? ( >=media-libs/mesa-9.1.6[gles2,${MULTILIB_USEDEP}] )
- glib? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
- lzo? ( >=dev-libs/lzo-2.06-r1[${MULTILIB_USEDEP}] )
- opengl? ( >=media-libs/mesa-9.1.6[egl,X(+),${MULTILIB_USEDEP}] )
- X? (
- >=x11-libs/libXrender-0.9.8[${MULTILIB_USEDEP}]
- >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
- >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
- >=x11-libs/libxcb-1.9.1[${MULTILIB_USEDEP}]
- )"
-DEPEND="${RDEPEND}
- X? ( x11-base/xorg-proto )"
-#[[ ${PV} == *9999* ]] && DEPEND="${DEPEND}
-# doc? (
-# >=dev-util/gtk-doc-1.6
-# ~app-text/docbook-xml-dtd-4.2
-# )"
-
-REQUIRED_USE="
- gles2-only? ( !opengl )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.12.18-disable-test-suite.patch
- "${FILESDIR}"/${PN}-respect-fontconfig.patch
-)
-
-src_prepare() {
- default
-
- if has_version ">=sys-libs/binutils-libs-2.34"; then
- eapply "${FILESDIR}"/${PN}-1.16.0-binutils-2.34.patch
- fi
-
- # tests and perf tools require X, bug #483574
- if ! use X; then
- sed -e '/^SUBDIRS/ s#boilerplate test perf# #' -i Makefile.am || die
- fi
-
- # Slightly messed build system YAY
- if [[ ${PV} == *9999* ]]; then
- touch boilerplate/Makefile.am.features
- touch src/Makefile.am.features
- touch ChangeLog
- fi
-
- eautoreconf
-}
-
-multilib_src_configure() {
- local myopts
-
- [[ ${CHOST} == *-interix* ]] && append-flags -D_REENTRANT
-
- use elibc_FreeBSD && myopts+=" --disable-symbol-lookup"
-
- # [[ ${PV} == *9999* ]] && myopts+=" $(use_enable doc gtk-doc)"
-
- ECONF_SOURCE="${S}" \
- ac_cv_lib_lzo2_lzo2a_decompress=$(usex lzo) \
- econf \
- $(use_with X x) \
- $(use_enable X tee) \
- $(use_enable X xlib) \
- $(use_enable X xlib-xrender) \
- $(use_enable X xcb) \
- $(use_enable X xcb-shm) \
- $(use_enable aqua quartz) \
- $(use_enable aqua quartz-image) \
- $(use_enable debug test-surfaces) \
- $(use_enable gles2-only glesv2) \
- $(use_enable glib gobject) \
- $(use_enable opengl gl) \
- $(use_enable static-libs static) \
- $(use_enable svg) \
- $(use_enable utils trace) \
- $(use_enable valgrind) \
- --enable-ft \
- --enable-interpreter \
- --enable-pdf \
- --enable-png \
- --enable-ps \
- --enable-script \
- --disable-drm \
- --disable-directfb \
- --disable-gallium \
- --disable-qt \
- --disable-vg \
- --disable-xlib-xcb \
- ${myopts}
-}
-
-multilib_src_install_all() {
- find "${D}" -name '*.la' -delete || die
- einstalldocs
-}
diff --git a/x11-libs/cairo/files/cairo-1.12.18-disable-test-suite.patch b/x11-libs/cairo/files/cairo-1.12.18-disable-test-suite.patch
deleted file mode 100644
index 6822121..0000000
--- a/x11-libs/cairo/files/cairo-1.12.18-disable-test-suite.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/Makefile.am b/Makefile.am
-index 03fa352..7e11d24 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -18,10 +18,6 @@ ACLOCAL_AMFLAGS = -I build ${ACLOCAL_FLAGS}
-
- DIST_SUBDIRS = src doc util boilerplate test perf
- SUBDIRS = src doc util
--# libpng is required for our test programs
--if CAIRO_HAS_PNG_FUNCTIONS
--SUBDIRS += boilerplate test perf
--endif
-
- configure: cairo-version.h
-
diff --git a/x11-libs/cairo/files/cairo-1.16.0-binutils-2.34.patch b/x11-libs/cairo/files/cairo-1.16.0-binutils-2.34.patch
deleted file mode 100644
index 03daac0..0000000
--- a/x11-libs/cairo/files/cairo-1.16.0-binutils-2.34.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/util/cairo-trace/lookup-symbol.c
-+++ b/util/cairo-trace/lookup-symbol.c
-@@ -145,14 +145,14 @@ find_address_in_section (bfd *abfd,
- if (symbol->found)
- return;
-
-- if ((bfd_get_section_flags (symtab->bfd, section) & SEC_ALLOC) == 0)
-+ if ((bfd_section_flags (section) & SEC_ALLOC) == 0)
- return;
-
-- vma = bfd_get_section_vma (symtab->bfd, section);
-+ vma = bfd_section_vma (section);
- if (symbol->pc < vma)
- return;
-
-- size = bfd_section_size (symtab->bfd, section);
-+ size = bfd_section_size (section);
- if (symbol->pc >= vma + size)
- return;
-
diff --git a/x11-libs/cairo/files/cairo-1.16.0-ft-Use-FT_Done_MM_Var-instead-of-free-when-available.patch b/x11-libs/cairo/files/cairo-1.16.0-ft-Use-FT_Done_MM_Var-instead-of-free-when-available.patch
deleted file mode 100644
index 3709c5a..0000000
--- a/x11-libs/cairo/files/cairo-1.16.0-ft-Use-FT_Done_MM_Var-instead-of-free-when-available.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 90e85c2493fdfa3551f202ff10282463f1e36645 Mon Sep 17 00:00:00 2001
-From: Carlos Garcia Campos <cgarcia@igalia.com>
-Date: Mon, 19 Nov 2018 12:33:07 +0100
-Subject: [PATCH] ft: Use FT_Done_MM_Var instead of free when available in
- cairo_ft_apply_variations
-
-Fixes a crash when using freetype >= 2.9
----
- src/cairo-ft-font.c | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/src/cairo-ft-font.c b/src/cairo-ft-font.c
-index 325dd61b4..981973f78 100644
---- a/src/cairo-ft-font.c
-+++ b/src/cairo-ft-font.c
-@@ -2393,7 +2393,11 @@ skip:
- done:
- free (coords);
- free (current_coords);
-+#if HAVE_FT_DONE_MM_VAR
-+ FT_Done_MM_Var (face->glyph->library, ft_mm_var);
-+#else
- free (ft_mm_var);
-+#endif
- }
- }
-
---
-2.19.2
-
diff --git a/x11-libs/cairo/files/cairo-1.16.0-pdf-add-missing-flush.patch b/x11-libs/cairo/files/cairo-1.16.0-pdf-add-missing-flush.patch
deleted file mode 100644
index 19345f1..0000000
--- a/x11-libs/cairo/files/cairo-1.16.0-pdf-add-missing-flush.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 4c8813f0eaacc32c27126ad2296951a626300b89 Mon Sep 17 00:00:00 2001
-From: Adrian Johnson <ajohnson@redneon.com>
-Date: Thu, 25 Oct 2018 18:46:17 +1030
-Subject: [PATCH] pdf: add missing flush
-
-Issue #342
----
- src/cairo-pdf-surface.c | 5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git a/src/cairo-pdf-surface.c b/src/cairo-pdf-surface.c
-index 7eb61aa1e..939b2d2d7 100644
---- a/src/cairo-pdf-surface.c
-+++ b/src/cairo-pdf-surface.c
-@@ -7711,6 +7711,11 @@ _cairo_pdf_surface_mask (void *abstract_surface,
- * and most common, case to handle. */
- if (_cairo_pattern_is_constant_alpha (mask, &extents.bounded, &alpha) &&
- _can_paint_pattern (source)) {
-+
-+ status = _cairo_pdf_operators_flush (&surface->pdf_operators);
-+ if (unlikely (status))
-+ goto cleanup;
-+
- _cairo_output_stream_printf (surface->output, "q\n");
- status = _cairo_pdf_surface_paint_pattern (surface,
- op,
---
-2.19.2
-
diff --git a/x11-libs/cairo/files/cairo-1.16.0-strings.patch b/x11-libs/cairo/files/cairo-1.16.0-strings.patch
deleted file mode 100644
index ee72f9d..0000000
--- a/x11-libs/cairo/files/cairo-1.16.0-strings.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-https://bugs.gentoo.org/726200
---- a/build/aclocal.float.m4
-+++ b/build/aclocal.float.m4
-@@ -31,10 +31,13 @@ int main() { return 0; }
-
- ]])], [
-
--if strings -a conftest$ac_exeext | grep noonsees >/dev/null ; then
-+# allow users to override default 'strings' with 'llvm-strings'
-+# or ${CHOST}-strings.
-+AC_CHECK_TOOL(STRINGS, strings)
-+if $STRINGS -a conftest$ac_exeext | grep noonsees >/dev/null ; then
- ax_cv_c_float_words_bigendian=yes
- fi
--if strings -a conftest$ac_exeext | grep seesnoon >/dev/null ; then
-+if $STRINGS -a conftest$ac_exeext | grep seesnoon >/dev/null ; then
- if test "$ax_cv_c_float_words_bigendian" = unknown; then
- ax_cv_c_float_words_bigendian=no
- else
diff --git a/x11-libs/cairo/files/cairo-respect-fontconfig.patch b/x11-libs/cairo/files/cairo-respect-fontconfig.patch
deleted file mode 100644
index b0a1b29..0000000
--- a/x11-libs/cairo/files/cairo-respect-fontconfig.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- cairo-1.7.6-orig/src/cairo-ft-font.c 2008-09-29 21:43:13.000000000 +0100
-+++ cairo-1.7.6/src/cairo-ft-font.c 2008-09-29 21:52:19.000000000 +0100
-@@ -1705,7 +1705,9 @@
- options->base.subpixel_order = other->base.subpixel_order;
- }
-
-- if (options->base.hint_style == CAIRO_HINT_STYLE_DEFAULT)
-+ options->base.hint_style = CAIRO_HINT_STYLE_DEFAULT;
-+
-+ if (other->base.hint_style != CAIRO_HINT_STYLE_DEFAULT)
- options->base.hint_style = other->base.hint_style;
-
- if (other->base.hint_style == CAIRO_HINT_STYLE_NONE)
diff --git a/x11-libs/cairo/metadata.xml b/x11-libs/cairo/metadata.xml
deleted file mode 100644
index 0ac435d..0000000
--- a/x11-libs/cairo/metadata.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <use>
- <flag name="opengl" restrict="&gt;=x11-libs/cairo-1.10.0">Build the OpenGL backend</flag>
- <flag name="gles2-only">Build the OpenGL ES 2 backend</flag>
- <flag name="glib">Compile with GLib Object System support</flag>
- <flag name="utils">Build support for Cairo script and trace utilities</flag>
- <flag name="valgrind">Built-in support to mark memory regions</flag>
- </use>
- <upstream>
- <remote-id type="cpe">cpe:/a:cairographics:cairo</remote-id>
- </upstream>
-</pkgmetadata>