summaryrefslogtreecommitdiff
path: root/dev-libs/highway/highway-0.12.2.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-06-25 21:31:09 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-06-25 21:31:56 -0400
commitfad053addbbd3f0768a6c68506c9e78f24d0b7f4 (patch)
tree874f3b14573b6dd097a82c293565ca83bd453914 /dev-libs/highway/highway-0.12.2.ebuild
parent598041ffdb7ad132a7d295aa57b49fbf70d6cf2e (diff)
downloadgentoo-overlay-fad053addbbd3f0768a6c68506c9e78f24d0b7f4.tar.xz
gentoo-overlay-fad053addbbd3f0768a6c68506c9e78f24d0b7f4.zip
dev-libs/highway, media-libs/libjxl: new packages
Diffstat (limited to 'dev-libs/highway/highway-0.12.2.ebuild')
-rw-r--r--dev-libs/highway/highway-0.12.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/highway/highway-0.12.2.ebuild b/dev-libs/highway/highway-0.12.2.ebuild
new file mode 100644
index 0000000..7f21cc2
--- /dev/null
+++ b/dev-libs/highway/highway-0.12.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Performance-portable, length-agnostic SIMD with runtime dispatch"
+HOMEPAGE="https://github.com/google/highway"
+SRC_URI="https://github.com/google/highway/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-cpp/gtest )"
+RDEPEND=""
+BDEPEND=""
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test ON OFF)
+ -DHWY_SYSTEM_GTEST=ON
+ )
+ cmake_src_configure
+}