summaryrefslogtreecommitdiff
path: root/media-sound/pamixer
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/pamixer')
-rw-r--r--media-sound/pamixer/Manifest1
-rw-r--r--media-sound/pamixer/metadata.xml11
-rw-r--r--media-sound/pamixer/pamixer-1.4.ebuild29
3 files changed, 41 insertions, 0 deletions
diff --git a/media-sound/pamixer/Manifest b/media-sound/pamixer/Manifest
new file mode 100644
index 0000000..996e474
--- /dev/null
+++ b/media-sound/pamixer/Manifest
@@ -0,0 +1 @@
+DIST pamixer-1.4.tar.gz 17614 BLAKE2B afd8b26d987d85c043e88870805b5504ff1f7fb96583b8002dfe106ba4d9a25cf429d7ff81d4ab8a2c75501d5926136089b68fe919c997dd3bb6d4662957c66b SHA512 e3916ed8dc020bb43e57994a9f35a506147a0fde42b88c30c661cbeffa40e0f74cae66cd015394e524684c32f9674de3e3763a1396a3e1b9aecbfdc3ed117fe4
diff --git a/media-sound/pamixer/metadata.xml b/media-sound/pamixer/metadata.xml
new file mode 100644
index 0000000..c0718b5
--- /dev/null
+++ b/media-sound/pamixer/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alex_y_xu@yahoo.ca</email>
+ <name>Alex Xu (Hello71)</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">cdemoulins/pamixer</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/pamixer/pamixer-1.4.ebuild b/media-sound/pamixer/pamixer-1.4.ebuild
new file mode 100644
index 0000000..a9205dd
--- /dev/null
+++ b/media-sound/pamixer/pamixer-1.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Pulseaudio command line mixer."
+HOMEPAGE="https://github.com/cdemoulins/pamixer"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/cdemoulins/pamixer"
+else
+ SRC_URI="https://github.com/cdemoulins/pamixer/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ dev-libs/boost
+ media-sound/pulseaudio"
+
+DEPEND="${RDEPEND}"
+
+src_install() {
+ dobin ${PN}
+ dodoc README.rst
+}