summaryrefslogtreecommitdiff
path: root/net-libs/neatvnc
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/neatvnc')
-rw-r--r--net-libs/neatvnc/Manifest1
-rw-r--r--net-libs/neatvnc/metadata.xml3
-rw-r--r--net-libs/neatvnc/neatvnc-0.2.0.ebuild41
-rw-r--r--net-libs/neatvnc/neatvnc-9999.ebuild12
4 files changed, 49 insertions, 8 deletions
diff --git a/net-libs/neatvnc/Manifest b/net-libs/neatvnc/Manifest
new file mode 100644
index 0000000..666d668
--- /dev/null
+++ b/net-libs/neatvnc/Manifest
@@ -0,0 +1 @@
+DIST neatvnc-0.2.0.tar.gz 549524 BLAKE2B 51d47232992af52c947af7172f09bf8bdfad0022543fa7962da84a1a830ba0c5c4e4c66d890822b366e5430ebd1524b5c4f132be3699f8361e882ba497595545 SHA512 74ff4ec6a492eaeead90b5e5d789885c709e90d50f682ad127f0f364264324ed0e6c66859f4254cbe9b79ebabb20974ceded67d5cab6a5fa8fd1f664ea18b15f
diff --git a/net-libs/neatvnc/metadata.xml b/net-libs/neatvnc/metadata.xml
index 004555a..a4e99d0 100644
--- a/net-libs/neatvnc/metadata.xml
+++ b/net-libs/neatvnc/metadata.xml
@@ -5,4 +5,7 @@
<email>alex_y_xu@yahoo.ca</email>
<name>Alex Xu (Hello71)</name>
</maintainer>
+ <use>
+ <flag name="benchmarks">Build and install benchmarks.</flag>
+ </use>
</pkgmetadata>
diff --git a/net-libs/neatvnc/neatvnc-0.2.0.ebuild b/net-libs/neatvnc/neatvnc-0.2.0.ebuild
new file mode 100644
index 0000000..458f18a
--- /dev/null
+++ b/net-libs/neatvnc/neatvnc-0.2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A liberally licensed VNC server library with a clean interface"
+HOMEPAGE="https://github.com/any1/neatvnc"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/any1/neatvnc.git"
+else
+ SRC_URI="https://github.com/any1/neatvnc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="benchmarks examples +jpeg ssl"
+
+DEPEND="
+ jpeg? ( media-libs/libjpeg-turbo )
+ ssl? ( net-libs/gnutls:= )
+ dev-libs/aml
+ sys-libs/zlib
+ x11-libs/pixman
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use benchmarks)
+ $(meson_use examples)
+ $(meson_feature jpeg)
+ $(meson_feature ssl tls)
+ )
+
+ meson_src_configure
+}
diff --git a/net-libs/neatvnc/neatvnc-9999.ebuild b/net-libs/neatvnc/neatvnc-9999.ebuild
index 6aff3d8..c1f9ddf 100644
--- a/net-libs/neatvnc/neatvnc-9999.ebuild
+++ b/net-libs/neatvnc/neatvnc-9999.ebuild
@@ -11,13 +11,13 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/any1/neatvnc.git"
else
- SRC_URI="https://github.com/any1/neatvnc/archive/v${PV}.tar.gz"
+ SRC_URI="https://github.com/any1/neatvnc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
fi
LICENSE="ISC"
SLOT="0"
KEYWORDS=""
-IUSE="examples +jpeg ssl"
+IUSE="benchmarks examples +jpeg ssl"
DEPEND="
jpeg? ( media-libs/libjpeg-turbo )
@@ -29,15 +29,11 @@ DEPEND="
RDEPEND="${DEPEND}"
BDEPEND=""
-src_prepare() {
- default
- sed -i -e '/x86_64-simd/s/^/#/' meson.build || die
-}
-
src_configure() {
local emesonargs=(
+ $(meson_use benchmarks)
$(meson_use examples)
- $(meson_feature jpeg tight-encoding)
+ $(meson_feature jpeg)
$(meson_feature ssl tls)
)