summaryrefslogtreecommitdiff
path: root/net-misc/wayvnc
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/wayvnc')
-rw-r--r--net-misc/wayvnc/Manifest1
-rw-r--r--net-misc/wayvnc/wayvnc-0.2.0.ebuild40
-rw-r--r--net-misc/wayvnc/wayvnc-9999.ebuild13
3 files changed, 52 insertions, 2 deletions
diff --git a/net-misc/wayvnc/Manifest b/net-misc/wayvnc/Manifest
new file mode 100644
index 0000000..a4bc175
--- /dev/null
+++ b/net-misc/wayvnc/Manifest
@@ -0,0 +1 @@
+DIST wayvnc-0.2.0.tar.gz 43615 BLAKE2B 7c663193160c97f3c1ac8641a2a9ccad99a9a4ca1d538ab64fe07fc5af759fb8abfac0b5fa9426de0d5e4453c3b60410edd882ffbf2a5d536b1634c714612f6d SHA512 42798ba2bcb96cb718bfe41c48a1525764ac26ea073ba69e26d327d422a379e93e5b57ba03290ca26d3c49c610e68a8459186fcf39998e74af7150df210ad9be
diff --git a/net-misc/wayvnc/wayvnc-0.2.0.ebuild b/net-misc/wayvnc/wayvnc-0.2.0.ebuild
new file mode 100644
index 0000000..54bcd82
--- /dev/null
+++ b/net-misc/wayvnc/wayvnc-0.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A VNC server for wlroots based Wayland compositors"
+HOMEPAGE="https://github.com/any1/wayvnc"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/any1/wayvnc.git"
+else
+ SRC_URI="https://github.com/any1/wayvnc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gbm"
+
+DEPEND="
+ dev-libs/aml
+ dev-libs/wayland
+ net-libs/neatvnc
+ virtual/opengl
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+ gbm? ( media-libs/mesa )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-libs/wayland"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_features gbm screencopy-dmabuf)
+ )
+
+ meson_src_configure
+}
diff --git a/net-misc/wayvnc/wayvnc-9999.ebuild b/net-misc/wayvnc/wayvnc-9999.ebuild
index a09e5dc..5b298a0 100644
--- a/net-misc/wayvnc/wayvnc-9999.ebuild
+++ b/net-misc/wayvnc/wayvnc-9999.ebuild
@@ -11,13 +11,13 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/any1/wayvnc.git"
else
- SRC_URI="https://github.com/any1/wayvnc/archive/v${PV}.tar.gz"
+ SRC_URI="https://github.com/any1/wayvnc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
fi
LICENSE="ISC"
SLOT="0"
KEYWORDS=""
-IUSE="examples"
+IUSE="gbm"
DEPEND="
dev-libs/aml
@@ -26,6 +26,15 @@ DEPEND="
virtual/opengl
x11-libs/libxkbcommon
x11-libs/pixman
+ gbm? ( media-libs/mesa )
"
RDEPEND="${DEPEND}"
BDEPEND="dev-libs/wayland"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_features gbm screencopy-dmabuf)
+ )
+
+ meson_src_configure
+}